IT Deployment Team

Selasa, 12 Agustus 2014

Konfigurasi VLAN Pada Switch Manageable dan Router Cisco

Pada artikel kali ini kita akan membahas mengenai cara "Konfigurasi VLAN Pada Switch Manageable dan Router Cisco". Sebelum masuk kebagian konfigurasi ada baiknya kita bahas terlebih dahulu pengertian dari VLAN (Virtual LAN) tersebut. VLAN (Virtual LAN) merupakan suatu tehnik pembuatan jaringan LAN secara virtual/abstract yang tak terbatas pada lokasi fisik seperti LAN (Local Area Network), dan hal ini mengakibatkan suatu network dapat dikonfigurasi secara virtual tanpa harus menuruti lokasi fisik peralatan.
0-1
Baiklah..., langsung saja kita masuk pada bagian konfigurasi VLAN (Virtual LAN) menggunakan satu unit switch manageable CISCO, satu unit Router, 5 unit HUB dan beberapa PC yang digunakan sebagai Client seperti pada topology jaringan VLAN (Virtual LAN) di atas.
Langkah-langkah dan konfigurasi yang dilakukan adalah sebagai berikut :

  1. Lakukan konfigurasi pada Router R1, sesuaikan IP Address dan interface yang digunakan serta berikan encapsulation dot1Q pada masing-masing interface guna mengaktifkan konfigurasi VLAN pada router R1, seperti gambar dibawah ini
    1. setting NAT di fa0 untuk VLAN
    Keterangan :
    - Untuk penomoran encapsulation dot1Q masing-masing interface cisco router, mangacu terhadap pen-tangging-an nomor VLAN pada switch manageable.
  2. Untuk mengecheck konfigurasi pada Router R1 setelah melakukan konfigurasi di atas, maka ketikkan perintah
    show running-config
    pada CLI Router Cisco anda dan pastikan sudah disetting IP Address dan Encapsulation dot1Q seperti gambar dibawah ini.
    1-3. check NAT
  3. Selanjutnya melakukan konfigurasi VLAN / tagging VLAN pada switch manageable seperti gambar berikut:
    2. tagging VLAN ON SW1
  4. Lakukan pengecekkan tagging vlan yang telah dilakukan tadi dengan mengetikkan perintah
    show vlan brief
    pada CLI (Command Line Interface) swicth manageable Cisco yang dikonfigurasi tadi, dan pastikan vlan sudah di tagging aktif pada masing-masing interface seperti tampilan berikut.
    3. check tagging VLAN brief
  5. Melakukan pengujian koneksi pada interface virtual yang sudah di tagging pada  interface fa0/0.x dengan encapsulation dot1Q pada router R1 dengan cara melakukan ping terhadap masing-masing IP Address yang sudah dikonfigurasi sebelumnya dan pastikan success seperti gambar berikut ini.
    4. Test Ping From Router To Gateway VLAN
  6. Tahap selanjutnya pengujian koneksi dengan cara melakukan ping dari CLI Router R1 ke IP Address salah satu PC client yang terdapat pada masing-masing jaringan VLAN dan pastikan koneksi success seperti gambar di bawah ini.
    5. Test Ping dari Cisco Router to PC Client
  7. Tahap selanjutnya adalah penguujian koneksi antar semasa PC pada masing-masing VLAN,
    dan pastikan success seperti pengujian di bawah ini :

    - Pengujian koneksi dengan melakukan ping dari PC client VLAN 1 ke PC Client VLAN 2.

    test from PC client VLAN 1 to PC Client VLAN2
    - Pengujian koneksi dengan melakukan ping dari PC client VLAN 2 ke PC Client VLAN 3.
    test from PC Client VLAN 2 to PC Client VLAN 3
    -Pengujian koneksi dengan melakukan ping dari PC client VLAN 3 ke PC Client VLAN 4.
    test from PC Client VLAN 3 to PC Client VLAN 4
    -Pengujian koneksi dengan melakukan ping dari PC client VLAN 4 ke PC Client VLAN 5.
    test from PC Client VLAN 4 to PC Client VLAN 5
    - Pengujian koneksi dengan melakukan ping dari PC client VLAN 5 ke PC Client VLAN 1.
    test from PC Client VLAN 5 to PC Client VLAN 1
Demikianlah cara konfigurasi VLAN (Virtual LAN) menggunakan switch manageable pada cisco router.
Semoga bermanfaat bagi anda...! ^

Configure IP Address on L2 Switch (Cisco Catalyst)



switch_iconSejatinya Switch adalah perangkat Layer 2 pada OSI Model, yang tugasnya hanya melakukan fungsi switching. Fungsi switching memang dinyatakan pada Layer 2 pada OSI Model, dan fungsi switching bisa digambarkan sebagai fungsi untuk memforward atau mengirimkan frame dari satu port ke port yang lain berdasarkan MAC Address tujuan. Dengan demikian maka Switch bekerja dengan hanya berpedoman pada MAC Address. Switch akan selalu merekam (merecord) MAC Address dari host-host yang terhubung dengannya.
Namun beberapa Switch sudah dikemas dengan Router, sehingga perangkat tersebut sebenarnya adalah Switch + Router, dan perangkat tersebut akhirnya bisa memainkan fungsi switching dan fungsi routing. Dari kondisi inilah maka sekarang santer para engineer IT menggunakan istilah Switch L2 atau Switch L3. Di mana Switch L2 adalah switch yang hanya menjalankan fungsi switching, sedangkan switch L3 mampu melakukan switching maupun routing. Dari sini pula Anda harus memahami bahwa switch L2 hanya berpedoman pada MAC Address sedangkan Switch L3 berpedoman pada MAC Address + IP Address. Jadi, jika sedang berdiskusi tentang Switch, Anda harus selalu memperjelas, Switch jenis apa yang sedang dibahas.
Mari kita kembali ke topik di atas, tentang Switch L2. Karena merupakan Switch yang bekerja hanya melakukan switching, maka switch L2 tidak menggunakan IP Address sebagai pedoman untuk bekerja (beroperasi). Sehingga konfigurasi IP Address pada switch L2 tidak perlu dilakukan. Anda dapat menjalankan fungsi-fungsi switching seperti VLAN, STP, VTP tanpa perlu memasang IP Address pada switch tersebut. Namun jika suatu saat Anda ingin melakukan konfigurasi maupun monitoring secara remote pada switch tersebut, maka IP Address wajib Anda konfigurasikan. Sehingga IP Address pada switch L2 lebih mengacu kepada IP Management, bukan IP Address yang digunakan untuk mengelola jaringan.
Contoh konfigurasi IP Address berikut ini merupakan contoh konfigurasi pada Switch Cisco (Catalyst), untuk switch dari vendor lain, tentunya memerlukan sedikit penyesuaian perintah. Karena hanya merupakan IP Management, maka IP Address yang bisa dikonfigurasikan pada switch L2 hanya ada 1 IP Address. IP Address tersebut juga tidak bisa dikonfigurasikan pada port-port switch, melainkan harus dikonfigurasi pada interface VLAN. Jika tidak ada konfigurasi VLAN, maka IP Address tersebut hanya bisa dikonfigurasikan pada VLAN 1, seperti perintah berikut ini.
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.253 255.255.255.0
Switch(config-if)#no shutdown
%LINK-5-CHANGED: Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
Switch(config-if)#exit
Switch(config)#^Z
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Untuk mengujinya, Anda bisa melakukan ping ke IP tersebut seperti berikut ini.
Switch#ping 192.168.1.253
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.253, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/4 ms
Anda juga bisa melakukan ping dari host, tentunya IP tersebut hanya bisa diping dari host yang berada di VLAN 1    , jika ternyata switch Anda menjalankan beberapa VLAN. IP Address tersebut tidak bisa diping dari VLAN yang lain, kecuali Anda sudah menjalankan InterVLAN Routing seperti pada artikel berikut ini.
Untuk membuka akses konfigurasi dengan menggunakan telnet dimana ‘123456’ digunakan sebagai password, maka konfigurasi berikut dapat digunakan.
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#enable password 123456
Switch(config)#line vty 0 4
Switch(config-line)#password 123456
Switch(config-line)#login
Switch(config-line)#^Z
Switch#
Pengujian akses telnet tersebut dapat dilakukan pada host, seperti berikut ini.
PC>telnet 192.168.1.253
Trying 192.168.1.253 …Open
User Access Verification
Password:
Switch>enable
Password:
Switch#
Akses remote terkadang akan dilakukan dari jaringan yang berbeda, ataupun dari VLAN yang berbeda. Pada kondisi ini, Anda harus mengkonfigurasikan default gateway pada Switch L2 tersebut. Tentunya default gateway adalah IP Address dari router yang menghubungkan switch tersebut dengan jaringan lain. Sebagai contoh, jika IP Address dari router Anda adalah 192.168.1.254, maka perintah yang dapat digunakan untuk mengkonfigurasikan default gateway adalah sebagai berikut.
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#ip default-gateway 192.168.1.254
Hasil akhir konfigurasi IP Address tersebut akan terlihat pada running configuration file seperti berikut ini.
Switch#sh run
Building configuration…
Current configuration : 1039 bytes
!
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Switch
!
enable password 123456
!
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface Vlan1
 ip address 192.168.1.253 255.255.255.0
!
ip default-gateway 192.168.1.254
!
!
line con 0
!
line vty 0 4
 password 123456
 login
line vty 5 15
 login
!
!
end
Tetaplah Anda ingat bahwa konfigurasi IP Address tersebut hanyalah IP Management. IP Address tersebut tidak akan digunakan switch dalam mengelola frame.
bersambung….   Cool

VLAN Configuration (incl. InterVLAN Routing)



switch_iconArtikel ini merupakan contoh implementasi (penerapan) dari artikel sebelumnya yang sudah membahas tentang konsep dari Virtual LAN (VLAN). Konsep dari Virtual LAN dapat Anda baca pada link berikut. Pada contoh implementasi ini, perangkat switch yang digunakan adalah Switch Cisco Catalyst. Jika Anda menggunakan perangkat dengan platform yang berbeda, kemungkinan akan ada beberapa penyesuaian perintah dalam mengkonfigurasikan VLAN. Konfigurasi yang dibahas pada artikel ini juga terbagi dua, yaitu konfigurasi dasar VLAN yang bertujuan melakukan segmentasi network dan konfigurasi InterVLAN routing yang bertujuan menghubungkan kembali segmentasi network tadi dengan menggunaan teknik routing. Untuk konfigurasi routing, contoh konfigurasi akan menggunakan Router MikroTik, sehingga jika ternyata Anda menggunakan router dengan platform yang berbeda, tentunya harus ada penyesuaian perintah konfigurasi.
Adapun contoh topologi yang akan digunakan adalah sebagai berikut :
 vlan_basic_topology_wm

Konfigurasi VLAN

Contoh konfigurasi VLAN berikut ini menggunakan Cisco Catalyst 2900 series. Dalam kondisi default Catalyst hanya memiliki satu VLAN yang dapat dilihat dengan menggunakan perintah  berikut ini.
Switch>enable
Switch#show vlan
VLAN Name                Status    Ports
—- —————— ——— ——————————-
1    default            active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
1002 fddi-default       act/unsup
1003 token-ring-default act/unsup

Dari uraian di atas terlihat bahwa Catalyst hanya memiliki satu VLAN dan VLAN tersebut memiliki parameter vlan-id=1. VLAN tersebut juga memiliki parameter name=default. Adapun port yang dimiliki, secara default VLAN 1 tersebut memiliki seluruh port yang ada pada switch tersebut, terlihat pada bagian Ports yang berisikan port Fa0/1 sampai dengan FaF0/24. VLAN 1 merupakan VLAN default dan VLAN ini tidak dapat dihapus.
Untuk menambahkan VLAN, dapat digunakan perintah seperti berikut ini.
Switch#
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z
Switch(config)#vlan 10
Switch(config-vlan)#name DIV-NETWORKING
Switch(config-vlan)#
Switch(config-vlan)#vlan 20
Switch(config-vlan)#name DIV-PROGRAMMER
Switch(config-vlan)#
Switch(config-vlan)#vlan 30
Switch(config-vlan)#name DIV-HRD

Setelah ditambahkan 3 VLAN, yang masing-masing adalah VLAN 10, 20 dan 30, maka jumlah VLAN yang telah dimiliki oleh Catalyst tersebut akan terlihat seperti berikut ini.
Switch#show vlan
 VLAN Name                 Status    Ports
—- ——————– ——— ——————————-
1    default              active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                    Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                    Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                    Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                    Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                    Fa0/21, Fa0/22, Fa0/23, Fa0/24
10   DIV-NETWORKING       active   
20   DIV-PROGRAMMER       active   
30   DIV-HRD              active   
1002 fddi-default         act/unsup
1003 token-ring-default   act/unsup
1004 fddinet-default      act/unsup
1005 trnet-default        act/unsup

 Dari uraian di atas terlihat bahwa Catalyst sudah memiliki 4 VLAN, yaitu VLAN 10, 20,30 dan tentunya VLAN 1 sebagai VLAN default. Namun VLAN 10, 20 dan 30 terlihat belum memiliki port, sehingga langkah konfigurasi berikut yang harus dilakukan adalah memindahkan beberapa port (sesuai scenario topology) untuk menjadi anggota dari VLAN 10, 20 maupun 30.
Pada skenario terlihat bahwa port Fa0/2 dan Fa0/3 harus menjadi anggota dari VLAN 10, perintah yang dapat digunakan adalah sebagai berikut.
Switch>
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface Fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10
 
 
Switch(config-if)#interface Fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10

Konfigurasi yang sama harus dilakukan untuk port-port yang lain sehingga akan menjadi anggota dari VLAN 20 dan VLAN 30 seperti berikut ini.
Switch(config-if)#
Switch(config-if)#interface Fa0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#
Switch(config-if)#interface Fa0/5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20
Switch(config-if)#
Switch(config-if)#interface Fa0/6
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30
Switch(config-if)#
Switch(config-if)#
Switch(config-if)#interface Fa0/7
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30

Hasil akhir dari konfigurasi dasar VLAN di atas akan terlihat seperti berikut ini, perhatikanlah bahwa baik VLAN 10, 20 maupun 30 sudah memiliki port masing-masing.
Switch#show vlan
 
VLAN Name             Status    Ports
—- —————- ——— ——————————-
1    default          active    Fa0/1, Fa0/8, Fa0/9, Fa0/10
                                Fa0/11, Fa0/12, Fa0/13, Fa0/14
                                Fa0/15, Fa0/16, Fa0/17, Fa0/18
                                Fa0/19, Fa0/20, Fa0/21, Fa0/22
                                Fa0/23, Fa0/24
10   DIV-NETWORKING   active    Fa0/2, Fa0/3
20   DIV-PROGRAMMER   active    Fa0/4, Fa0/5
30   DIV-HRD          active    Fa0/6, Fa0/7

Konfigurasi InterVLAN Routing

Pada konfigurasi dasar VLAN sebelumnya, jaringan pada Catalyst tadi telah tersegmentasi secara virtual menjadi 3 jaringan. Untuk menghubungkan ketiga jaringan tersebut, maka diperlukan sebuah router. Selain itu Anda juga harus mengkonfigurasikan sebuah port untuk menjadi trunk yang dapat berfungsi sebagai penghubung semua VLAN ke router. Pada contoh scenario, port Fa0/1 adalah port yang akan menjadi trunk.
Perintah yang dapat digunakan untuk membuat port Fa0/1 menjadi trunk adalah sebagai berikut.
Switch#
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#interface Fa0/1
Switch(config-if)#switchport mode trunk

Setelah itu, konfigurasi dilanjutkan ke Router MikroTik yang bertugas menghubungkan VLAN tersebut, maupun menghubungkan VLAN tadi ke Internet. Langkah pertama yang harus dilakukan pada Router MikroTik adalah membuat 3 (tiga) interface VLAN pada interface ether2. Adapun perintah yang dapat digunakan adalah sebagai berikut :
[admin@KungFu] > interface vlan add name=DIV-NETWORKING vlan-id=10 interface=ether2
[admin@KungFu] > interface vlan add name=DIV-PROGRAMMER  vlan-id=20 interface=ether2     
[admin@KungFu] > interface vlan add name=DIV-HRD vlan-id=30 interface=ether2        
[admin@KungFu] > interface vlan print
Flags: X – disabled, R – running, S – slave
 #    NAME                MTU ARP        VLAN-ID INTERFACE                                      
 0 R  DIV-NETWORKING     1500 enabled         10 ether2                                         
 1 R  DIV-PROGRAMMER     1500 enabled         20 ether2                                          
 2 R  DIV-HRD            1500 enabled         30 ether2              

Yang harus diperhatikan pada saat membuat interface VLAN pada Router MikroTik adalah parameter vlan-id yang harus sama dengan vlan-id yang sudah dikonfigurasikan pada Catalyst. Begitu juga dengan parameter interface=ether2, yang memperlihatkan bahwa interface virtual LAN tersebut akan menginduk ke interface fisik ether2.
Langkah berikutnya adalah memberikan IP Address pada masing-masing interface VLAN pada Router MikroTik. IP Address ini sangat penting karena akan menjadi default gateway bagi setiap komputer yang ada pada VLAN 10, 20 dan 30. Adapun perintah yang dapat digunakan adalah sebagai berikut.
[admin@KungFu] > ip address add address=192.168.1.1/24  interface=DIV-NETWORKING
 [admin@KungFu] > ip address add address=192.168.2.1/24   interface=DIV-PROGRAMMER   
 [admin@KungFu] > ip address add address=192.168.3.1/24    interface=DIV-HRD         
 
[admin@KungFu] > ip address print
Flags: X – disabled, I – invalid, D – dynamic
 #   ADDRESS            NETWORK         INTERFACE                                                                          
 0   100.1.1.2/30       100.1.1.0       ether1                                                                              
 1   192.168.1.1/24     192.168.1.0     DIV-NETWORKING                                                                     
 2   192.168.2.1/24     192.168.2.0     DIV-PROGRAMMER                                                                      
 3   192.168.3.1/24     192.168.3.0     DIV-HRD       

Anda dapat melanjutkan konfigurasi dengan mengaktifkan DHCP Server pada masing-masing interface VLAN tersebut. Tentunya konfigurasi lainnya seperti Default Route, DNS maupun Masquerade akan dibutuhkan jika ingin membuat VLAN tersebut terhubung ke Internet.

Jaringan VLAN dengan Switch Manageable



Membuat Jaringan VLAN dengan Menggunakan Switch Manageable
http://2.bp.blogspot.com/-TdGaH6zL6HQ/Ui6i8g811KI/AAAAAAAAAF4/i-NKPd_DJ_I/s1600/image001.png

Media pembelajaran ini berisi tutorial tentang membuat jaringan VLAN menggunakan switch Manageable.
Bagaimana proses pembuatannya? Ikutilah Langkah-langkah berikut :

Membuat VLAN guru dengan VLAN ID 200
Switch>enable
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 200
Switch(config-vlan)#name guru
Switch(config-vlan)#ex

Membuat VLAN murid dengan VLAN ID 210
Switch#configure terminal
Enter configuration commands, one per line.  End with CNTL/Z.
Switch(config)#vlan 210
Switch(config-vlan)#name murid
Switch(config-vlan)#ex

Menyediakan port fa0/1 yang diberikan VLAN guru
Switch(config)#interface fa0/1
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 200
Switch(config-if)#ex

Menyediakan port fa0/2 yang diberikan VLAN guru
Switch(config)#interface fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 200
Switch(config-if)#ex

Menyediakan port fa0/3 yang diberikan VLAN murid
Switch(config)#interface fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 210
Switch(config-if)#ex

Menyediakan port fa0/4 yang diberikan VLAN murid
Switch(config)#interface fa0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 210
Switch(config-if)#ex

Seting IP Address pada PC0
IP Address: 10.100.30.1
Netmask: 255.0.0.0

Seting IP Address pada PC1:
IP Address: 10.100.30.2
Netmask: 255.0.0.0

Seting IP Address pada PC2:
IP Address: 192.168.1.1
Netmask: 255.255.255.0

Seting IP Address pada PC3:
IP Address: 192.168.1.2
Netmask: 255.255.255.0